
FOSSPICKS

www.linuxvoice.com68

Rock Ridge and Joliet filesystem extensions for CDs/DVDs provide 
better integration with Unix and Windows systems respectively.

ISO Master shows the 
estimated size of the 
resulting ISO on the 
right-hand size, between 
the two panes.

Sparkling gems and new
releases from the world of 
Free and Open Source Software

Mike Saunders has spent a decade mining the internet for free 
software treasures. Here’s the result of his latest haul…

If you’ve ever taken a peek at the
genisoimage or mkisofs
manual pages, you’d be forgiven

if you come away shuddering. The
former is a whopping 1,596 lines
long – and that’s not a bad thing,
because its level of detail is superb.
But the number of options included
in these command line CD/DVD
creating tools is overwhelming,
especially if you’re not au fait with
making disc images and you just
want to knock together a quick
backup DVD.

ISO Master aims to be a simpler
and friendlier graphical alternative.
But it’s not just limited to basic data
discs; it has options for making
bootable discs with multiple
filesystem formats as well. GTK 2 is
used to provide the interface, so to
compile ISO Master from source,
you’ll need the development
packages installed (try libgtk2.0-
dev under Debian/Ubuntu-based

FOSSpicks

distros). Extract the .tar.bz2 file,
change into the resulting directory
with cd and run make followed by
sudo make install. Then start the
program with isomaster.

Functional minimalism
Many disc authoring tools clog up
the screen with toolbars, panels
and directory trees all over the
place, but ISO Master has just two
panels: the top one browses your
filesystem, and the bottom one
browses the contents of the disc.
You can open an existing ISO image
by double-clicking on one in the top
panel, or create a new image via the
File > New menu. Click a file or
directory in the top panel, then Add

to add it to the DVD, or Extract to
remove a file from an ISO.

To change filesystem options, go
to File > Properties; there you can
choose whether Rock Ridge and
Joliet extensions should be enabled
(a good idea, as these let discs use
longer filenames), and you can also
enter text for the volume name and
publisher. Use the Tools > Boot
Record menu to add a boot image
to a disc, eg if you’re making a
bootable Linux distro.

When you’re finished creating the
disc, click File > Save As and
provide a filename. ISO Master will
generate <filename>.iso, ready to
be burned to a CD/DVD-R or booted
in a virtual machine such as
VirtualBox. It’s simple, fast and
trouble-free – great work, team!

ISO Master 1.3.11
CD/DVD image editor

PROJECT WEBSITE
www.littlesvr.ca/isomaster

“ISO Master aims to be a simpler 
and friendlier graphical alternative 
to genisoimage and mkisofs.”



FOSSPICKS

www.linuxvoice.com 69

Dianara crams plenty of information and widgets into its window, 
making better use of space than the web interface.

The big social networking
sites, such as Facebook,
Google+ and Twitter, have

two major problems: they’re all
massively centralised, and they
retain scary amounts of personal
data about us. It’s not all bad
though. Pump.io is an example of a
social networking service that is
both open source and decentralised
– that is, anyone can run a server
that becomes part of the network.
So no single company owns or
controls the service, and if one
machine goes down, users
registered on another machine
won’t be affected. Anyone can set
up their own Pump.io node (even
on low-spec kit such as a
Raspberry Pi), so if anyone is
interested in a tutorial, let us know.

Anyway, Dianara is a graphical
application for accessing your
Pump.io account without having to
go through a web browser. Its
interface is built using Qt, and  to
install it you’ll need the qjson-devel, 
qoauth-devel and libmagic-devel
packages. Extract the dianara-
v1.2.0.tar.gz archive and see the
INSTALL file inside for detailed
installation instructions, including a
helpful list of dependencies for
many popular distros.

When you first start Dianara,
you’ll be prompted to link it to your

Pump.io account. And if you don’t
have one of those yet, you can get
one from many different sites – we
used https://pumpit.info. 
Reassuringly, the Pump.io service
doesn’t just let random applications
connect to your account and post
things (a sure source of spam), so
Dianara needs a validation key and
confirmation from the web
interface that you want to link the
program to your account.

Pump.io up the volume
Pump.io is a relatively simple
service compared with the
heavyweights of Facebook and
Google+, and this is reflected in the
application. You can post
messages to your timeline (plain
text, or with media attachments),
follow people to see what they’re up
to, and click stars on posts to add
them to your Favourites list. You
can also add comments to posts,
share them with other people, and
set up lists (to separate friends
from colleagues, for instance).

In all it’s an attractive and
newbie-friendly program that still

packs in a good amount of
functionality. It’s also decently
configurable, with options for
changing how notifications work
and how often the timeline should
be updated. There’s not much in the
way of online help, although the tips
are useful.

The biggest problem for Pump.io
is its relatively small userbase. But
it’s a great system, so if we all get
on Pump.io, maybe we can finally
show that info-hoarding Zuckerberg
fella who’s boss…

Dianara 1.2.0
Social networking client

“Maybe we can finally show that 
info-hoarding Zuckerberg fella 
who’s boss?”

How it works: Get posting on Pump.io

Sign up
Create an account at https://pumpit.info, then 

start Dianara and link it to your account. (You will be 
asked to get a verification key from the site.)

1 Add contacts
Click the Contacts tab and add people you 

know. If you don’t know anyone yet, try adding evan@
e14n.com, aka Evan Prodromou, Pump.io’s creator.

Post a message
Click the Timeline tab and click in the text field 

at the top. Give your post a title, add some text or an 
image, and click Post to share with your followers.

2 3

PROJECT WEBSITE
http://jancoding.wordpress.com/
dianara
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With the --overlay 
option, file changes 
inside a Firejail session 
are forgotten when the 
session ends.

Containers, virtual machines,
chroot jails… There are many
ways to run programs in

restricted sandboxes, where they
can’t interfere with the rest of the
system. This is great idea if you’re
ramping up security measures, or
you’re running a program from an
unknown source and want to make
sure it doesn’t hose your distro.
Setting up these sandboxes can be
tricky, though – so Firejail provides
an easier alternative.

Both RPM and Deb binary
packages are available to download
from the program’s website, or you
can compile it from its source code
(it has no unusual dependencies
and should install on any recent
distro). Once you have it installed,
run it along with a program like so:
firejail bash

Now, inside the new Bash shell
session, enter ps ax. Notice

something strange? Yes, there are
only two processes listed – and PID
1 (which is normally /sbin/init) is
the current Bash process. Firejail
has created its own process
namespace for this Bash session,
so it can’t poke around and discover
anything else that’s running.
Another useful option is:
firejail --overlay bash

If you have OverlayFS enabled in
your kernel, this will overlay a
temporary filesystem onto the
current one. So you can create and
modify files inside the jailed
environment, but when you access
it, all of the changes are forgotten.
This is great when you have
programs that need to write files,
but you want to revert to the original
state of the filesystem when you
close them.

Firejail includes various other
ways to sandbox programs, like

providing them with their own TCP/
IP stacks, and it includes a simple
monitoring tool (firemon, which
shows activity in Firejail sessions).
In all it’s a simple and user-friendly
way to run applications in restricted
environments, so if you’ve been
bamboozled with VMs, containers
and chroot commands, give it a go.

Firejail 0.9
Process sandboxing tool

Fancy some Top Albania 
Radio? Or perhaps some 
Bluegrass Jamboree? 
Streamtuner2 has it all.

For various reasons, mostly to
do with mountains and
wheat beer, this author

started learning German four years
ago. It has been a tough ride, but
one of the things that helped is the
abundance of German radio
stations on the internet.

There are thousands of radio
stations being broadcast via the
internet, and while you can access
them via your browser, it’s easier
and faster to search via a dedicated
program. Streamtuner2 is one such
app: it’s written in Python with GTK
as its front-end, so you’ll need the
pygtk package installed to run it.
Generic Deb and RPM packages
are available on the project’s
website, and we had no problem
installing the Deb on Ubuntu 13.10.

Streamtuner2 doesn’t play audio
itself – you’ll need a standalone

player such as Audacious to hear
the streams. When you start
Streamtuner2 for the first time, it
asks you which player you want to
use. Then it presents you with
several internet radio station
directories, some of which didn’t
work in our testing, which was
slightly annoying. We had the most
luck with the SHOUTcast and Music
Goal services.

With thousands of stations to
browse, across all manner of
genres and languages, it can be
difficult to remember your
favourites. So Streamtuner2
includes a handy bookmarking
system: right-click on a station and

choose bookmark. You’ll then find
that station under the Bookmarks
tab, on the far left of the tab bar.

Streamtuner2 has some rough
edges in the layout and wording
used in the interface, but it’s still a
good way to explore the vast world
of internet radio.

Streamtuner2 2.1.0
Internet radio browser

“Streamtuner2 includes a handy 
bookmarking system.”

PROJECT WEBSITE
http://l3net.wordpress.com/projects/
firejail

PROJECT WEBSITE
http://milki.include-once.org/
streamtuner2
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Compression Profiles 
make it a one-click job 
to choose formats and 
options.

PeaZip is a graphical
application for creating and
extracting compressed

archives, and as of the latest
release, it supports over 150 archive
formats. (Yes, 150 – that’s not a
typo!) Along with the usual
suspects such as Zip and .tar.gz, 
the program can work with
relatively obscure formats such as
.arc and .arj. If you created some
archives with a random piece of
shareware on your Amiga back in
the early 90s, chances are that
PeaZip can still open them.

PeaZip can use GTK or Qt for its
interface, and along with Deb and
RPM packages, there are “portable”
versions that can be run without
installation. Just extract the .tar.gz
file, jump into the resulting directory,
and run peazip inside. Packaging
up software to run across the
myriad Linux distros out there is

tiring work, so kudos to the devs for
putting a lot of effort in.

PeaZip’s interface is attractive,
clean and largely self-explanatory,
so we won’t dwell on it here, but
instead focus on the new features.
The biggest addition in 5.3 is the
Compression Profiles. Go to File >
Create Archive, and in the dialog
that appears, click on the down
arrow to the left of the OK button.
This provides some pre-created
settings for compression, such as
“7zip with password” or “Keep
output under 10MB for email
attachments”. These shortcuts are
very handy when you don’t have
time to poke around inside
individual settings boxes.

Also in 5.3 are improvements to
the file manager (such as a better
treeview sidebar), while bookmarks
can be sorted. The inclusion filters
that you can use when choosing
which files should go in an archive
are more flexible too. PeaZip just
keeps getting better and better –
it’s an outstanding piece of work.

PeaZip 5.3
Compression utility

“PeaZip’s interface is attractive, 
clean and self-explanatory.”

gpgpwd is low on 
dependencies, uses 
existing tools (GPG) for 
security, and works 
without any faffing 
around.

In the wake of the Heartbleed
OpenSSL vulnerability most
major sites and services have

recommended that users change
their passwords – and, of course,
it’s a bad idea to use the same
password across multiple sites.
So we’ve all ended up with another
bunch of passwords to remember,
and for those of us without
incredible memories, a password
manager comes in mightily useful.

gpgpwd is a great little manager
written in Perl and requiring the
JSON and Try-Tiny modules, which
are available as libjson-perl and
libtry-tiny-perl in Debian/Ubuntu-
based distros. Extract the program,
switch into the resulting directory
and install as follows:
tar xfv gpgpwd-0.4.tar.bz2
cd gpgpwd-0.4
sudo make install

If you’ve used the GPG encryption
tools before, you’re ready to go –
but if not, enter gpg --gen-key to
create a new encryption key. You’ll
be prompted for a password, and
this will become the master
password you’ll use to access other
passwords via gpgpwd. To create a
new entry in gpgpwd’s database:
gpgpwd set somesite.com

Here, gpgpwd will ask you for a
password for somesite.com, or
offer to create a new one. A few
commands are available for
generating passwords:
/alphanumeric 20, for instance, will
generate a random 20-letter/
number password. Hit Enter, and
the password will be stored. To
retrieve it in future:
gpgpwd get somesite.com

When you do this, you’ll be
prompted for your master

password – that is, the GPG
password you used during the
--gen-key command earlier.
Passwords are stored in the
encrypted .gpgpwddb database file
in your home directory, and to
remove them from the database,
use gpgpwd remove followed by
the site name.

gpgpwd 0.4
Password manager

PROJECT WEBSITE
http://peazip.sourceforge.net

PROJECT WEBSITE
http://random.zerodogg.org/gpgpwd
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After we’ve modified 
test.txt, Checkit 
gives us a red “failed” 
message to show that 
the file has changed.

If you’ve ever downloaded a
large file such as a distro CD/
DVD ISO image, you’ll probably

have seen a file called MD5SUM (or
SHA256SUM) to go alongside it.
This contains a checksum – a
sequence of characters that can be
used to check the integrity of the
download. This is all good, but if
you need to watch the integrity of
many files on your filesystem, it
becomes a bit fiddly to have foo.
md5sum and bar.md5sum files all
over the place. And then you have
to run the md5sum tool each time…
Checkit makes the whole process a
lot easier by embedding a
checksum into a file’s extended
attributes (so you don’t need
separate files) and letting you do
batch checks on multiple files.

Its only dependency is libattr1-
dev, and you install it with the usual
./configure, make and make install

(as root) procedure. Go into a
directory containing files that you
want to check, and run this:
checkit -s -o *

This stores and overwrites the
checksum for all the files in the
current directory, storing the
checksums in the file’s extended
attributes (ie the bit of the
filesystem that contains metadata
about a file, such as its creation
date). Your filesystem needs to
have extended attribute support for
this to work, but if you’re using
ext3/4, XFS, JFS or BTRFS you’ll be
fine. Now modify one of the files,
and then run:
checkit -c *
This checks all files against their

checksums, and shows you which
files have changed.

Checkit isn’t a replacement for a
full-on intrusion detection system,
and it’s limited to certain formats
and filesystems (many archive
formats don’t save extended
attributes, for instance). But for
simple jobs it works just fine.

Checkit 0.2.0
File integrity checker

“Chechit embeds a checksum into 
a file’s extended attributes.”

LE is reasonably 
configurable, and if you 
don’t like the default 
colour scheme, others 
are available.

In last issue’s cover feature we
gave mad props to Vim, but we
appreciate that not everyone

likes its mode-based operation and
(initially) confusing keybindings.
Emacs is a hugely powerful
alternative, but it can still be tricky
to learn all the Ctrl/Meta+key
commands. If you’ve come from an
MS-DOS background, you might
want a more accessible editor that
presents its options in familiar
menus – and LE could be exactly
what you need.

Despite having decent knowledge
of C, we couldn’t get past the fiddly
errors that cropped up when we
tried to compile LE from source, so
we converted the RPM package
from http://lav.yar.ru/download/le/
binaries/ to a Deb for our Ubuntu
system using alien. This is a very
handy tool for converting packages

between formats. We used:
alien --to-deb le-1.15.0-1.x86_64.rpm

Along the bottom you’ll see a
status line containing information
about the current file, while hitting
F10 (or Ctrl+B) opens the menu at
the top. Use the arrow keys to
navigate through the menus, and
enter to open them. You’ll also see
keyboard shortcuts in the menu –
eg F2 to save, or Ctrl+F to search.

Back to the old house
LE includes all the common
features you’d expect in a decent
editor: syntax highlighting, search
and replace with regular
expressions, line and column
selections (with many available
operations to perform on them),
UTF-* support, custom colours and
more. It can be used as a hex editor
(see the -h option), and even lets

you convert between Unix and
DOS-style text files (they have
different line ending characters).

While it’s not the ultimate kitchen
sink editor like Emacs, it does 95%
of what most people need, and the
menu-based interface makes it
easy to pick up.

LE 1.15
Text editor

PROJECT WEBSITE
http://dennisk.customer.netspace.net.
au/checkit.html

PROJECT WEBSITE
https://github.com/lavv17/le
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https://launchpad.net/pybik/

PROJECT WEBSITE
www.nongnu.org/galois

Holtz isn’t a single game
as such – it’s an engine
for four board games.

And these aren’t your common-
or-garden board games either, but
abstract strategy games that take
a while to get your head around.
Sadly, the README file is blank
and the INSTALL file contains
generic GNU build instructions
from 2002, so here’s how to
compile it: install the wxWidgets
development packages from your
distro’s package manager (eg
libwxgtk2.8-dev and
wx2.8-headers) along with Boost
(libboost-dev). Then run
./configure, make and sudo
make install, followed by holtzt to
start the game.

Click File > New in the menu to
choose one of the four included

games. The first, Zertz, is designed
for two players, but if you’re on your
own, you can set up the computer
as an AI player. It combines
elements of draughts and solitaire,
and every time you lay a piece, you
remove a space on the board, so
the playing area gradually gets
smaller. (The rules are complicated,
so click Help > Contents in the
menu to get the full description.)

Game of four halves
Dvonn, meanwhile, is another two-
player game, which involves
stacking pieces on top of one
another to control areas of the
board, while Relax is a good
single-player game where you have
to score points by placing colour-
aligned pieces. The final game,
Bloks, is for two or four players and

involves racing from the corners
to grab as much space on the
board as possible.

Holtz is a brilliant little package,
and some of the games will keep
you busy for hours, even if they
seem rather odd at first.

FOSSPICKS Brain Relaxers

This is Relax, where 
your goal is to place 
pieces so that the 
coloured lines extend 
for as long as possible.

Holtz 1.4.0
Board game compilation

Tetris has pretty much
been done to death at this
point, although we still see

new versions on Freecode.com
every week. So at first we almost
skipped over Galois, but then we
saw the screenshots, and just
had to try it. Galois is a Tetris
engine that includes the classic
game, but also some variants
with different shapes. To compile
it, you’ll need GTK 2.4 and
LibXML++ 2.6; in Debian and
Ubuntu-based distros, these are
provided in the libgtkmm-2.4-dev
and libxml++2.6-dev packages.

When you start Galois, you’re
presented with a grand total of
nothing. Just a grey screen. Click
Game > New in the menu,
however, and a version of the

regular Tetris game will kick off. By
default, Galois’s Tetrisy games run
at a fair pace, but you can change
that by going to Game > Stop and
then Game > Preferences (see
“Initial speed level”). This is also
where you’ll choose a different
format, such as hexagonal or
triangular bricks.

I’ll have a T please, Bob
We love the hexagonal version: it’s
similar enough to Tetris that it
doesn’t take long to pick up, and
many of the tactics you use in the
classic game still apply. The
controls are as usual for Tetris, but
the unusual shapes make the game
different enough to exercise other
neurons in your noggin, and
especially difficult at times too.

There’s only one flaw: pressing
Esc to pause leaves the screen
intact, so you can plan your next
move (the screen goes blank in
most Tetris variants). We’ll submit
a bug report… 

What’s this – Tetris? Or 
Blockbusters? Or some 
ker-azy mutant hybrid 
of both?

Galois 0.3
Tetris variant bundle

PROJECT WEBSITE
http://holtz.sourceforge.net


